Resolved on Meta side. Production rate of subcode 3858504 dropped to zero after 2026-05-07 18:26 UTC, and accounts that were rejecting payloads earlier in the day now accept identical requests. We believe Meta rolled back the deprecation enforcement that had been spuriously rejecting calls — including calls whose payload did not contain standard_enhancements. No Pipeboard code change is required for users to be unblocked; retrying the original request should now succeed. We will reopen this incident if 3858504 returns to non-zero in production logs.
Posted May 07, 2026 - 21:34 UTC
Update
Update — improved error response now live.
We have shipped an improved error response in the Meta Ads MCP. When a creative POST fails with subcode 3858504 and your payload does not actually contain standard_enhancements, the response now walks you through the most likely unblock — Ads Manager Advertising settings -> Creating ads -> Advantage+ creative -> turn off Standard enhancements — with a deep-link straight to the right screen for the affected ad account. If the toggle is missing or grayed out (Meta has been removing it from some accounts as part of the same rollout), the response also names the account-switch fallback: the same payload usually still succeeds on other ad accounts the same user has access to.
We are also reaching out by email to the small set of users we have evidence of being blocked.
The underlying Meta-side deprecation rollout is unchanged on their side; we will continue to update this incident as we learn more.
Posted May 07, 2026 - 16:11 UTC
Investigating
Some Meta ad accounts cannot create or duplicate ad creatives via the Meta Ads MCP. Meta returns error subcode 3858504 ("Including standard_enhancements field in creative has been deprecated").
What is happening Meta is mid-rollout of deprecating the standard_enhancements field inside creative_features_spec. On affected ad accounts, Meta auto-injects the deprecated field server-side at write time, then immediately rejects the request because the field is no longer accepted on POST. The same payload usually still succeeds on other ad accounts the same user has access to.
Symptoms - create_ad_creative, bulk_create_ad_creatives, update_ad_creative, create_ad, and duplicate_creative all fail with error_subcode 3858504. - The error fires regardless of whether the caller includes creative_features_spec, sends an empty {}, sets disable_all_enhancements: true, or specifies individual OPT_OUT keys. - The field is never present in the request the caller sends; Meta is adding it server-side from an account-level Advantage+ Creative default.
What you can try 1) Open Meta Ads Manager, switch to the affected ad account, then All tools -> Advertising settings -> Creating ads -> Advantage+ creative. Turn off "Standard enhancements" (and "All optimizations" if present) and Save. This toggle is the most likely source of the server-side auto-injection. Some affected users have reported the toggle is missing or grayed out on their account; in that case option 2 is the only short-term unblock. 2) If you have access to a different ad account, try the same payload there. The issue is scoped to specific accounts in our evidence so far.
What we are doing We are tracking this and improving the error messages users see in the MCP response. There is no API workaround we can apply on your behalf; Meta does not expose the relevant account-level Advantage+ Creative default through the Marketing API. We will update this incident as we learn more.
Posted May 07, 2026 - 15:01 UTC
This incident affected: Meta Ads MCP and Creatives.